Skip to main content

Generate and Submit an Electronic File

Modified: 7 Sep 2026 ProContractor Year-End Help

If you're using Greenshades, you can create an electronic file and submit it online or via mail.

Install Greenshades Center and Validate Greenshades Center.
Important: If you are filing in California, New Jersey, or New York, review Important Filing Differences and Exemptions.
You can generate electronic files for your choice of Forms, some more than one at the same time.
  1. Open the Electronic Filing screen.
  2. Note the active company and change it if needed.
  3. In the Filing Type area, select which file you want to create.
    Note: You can generate an electronic file for Forms W-2 and Form 940 at the same time. All other files must be generated separately.
  4. If you selected New Hire, completed the date range fields.
  5. In the Tax Year field, select the tax year for the electronic file(s).
  6. If the Tax Period field appears, select the tax quarter for the file you're submitting.
  7. Select Generate.
  8. If the Welcome to the Greenshades Center window appears, select Close.
  9. Select Create E-File Returns.
  10. If the Employee Identity Verification window appears, choose one:
    • If you want Greenshades Center to verify the identity of your employees with the Social Security Administration, review the Terms of Use, select the Yes, please verify my employee information option button, and then select Next.
    • Select No and then select Next.
  11. In the Method column for each electronic file you're creating, choose one:
    • Select Internet to submit the file over the Internet to the tax authority.
      Note: Copies of electronic files are placed in the folder specified on the Advanced tab of the Greenshades Settings window. The default location is:

      C:\Program Files (x86)\Greenshades Software\Greenshades Center\Data

    • Select Media to copy the electronic file to a disk and mail it to the tax authority.
  12. In the Build column, choose Select All or select the checkbox for just the electronic file(s) you want to create.
    The application will lead you through the steps for each selected tax authority and submission method separately.
  13. Select the Check here if you would like the ability to edit your data prior to creating your electronic file (Advanced) checkbox to review your data and add company contact information.
    Note: Don't make changes to the data in Greenshades Center other than adding company contact information. Changes made in Greenshades Center are not written back to ProContractor, resulting in discrepancies between your printed tax forms and reports and the data in the electronic file.
  14. Select Next.
  15. Use the Editor pop-up window to review your data and edit the contact information as needed.
    • Select a level in the left pane to view the information at that level.
    • Select a tab to view it.
    • The Detail View tab and the List View tab in the right pane display different information.
  16. Select File > Done Editing.
    Note: If there are errors, select Select to provide information to enter the missing information. Some information may be entered directly on this screen, while some information may require you to go back to the Editor pop-up window.
  17. Select Select Here to Begin Filing.
  18. Select Save E-File to save the file locally.
  19. In the Save File pop-up window, select the folder location where you want to save the file.
    Tip: Create a folder structure by tax authority to save files for electronic filing.
    CAUTION: Greenshades creates the file name according to tax authority requirements. Do not change it.
  20. Select Save.
  21. Select Next.
  22. Choose how to proceed:
    • If you're filing over the internet, choose Automatic Submission or choose Manual Submission and review the instructions for filing manually.
    • If you're using media, select the drive for the media and select Save.
  23. Select Next.
  24. Review the company contact information and modify as needed.
    • If you're filing over the internet, review the company contact information and modify as needed.
    • If you're using media, review the instructions for creating labels and the mailing envelope.
  25. Select Next.
    Note: Depending on the tax authority, there may be additional information screens. Review these screens and select Next.
  26. Select Finish.
Submit

Table of Contents