주요 콘텐츠로 건너뛰기

모델 또는 도면에서 객체 이동

Modified: 11 3월 2026 Tekla Structures 2026
2026
Tekla Structures

Tekla Structures에서는 특히 모델에서 객체를 다양한 방법으로 이동할 수 있습니다. 객체를 이동하면 Tekla Structures는 컴포넌트를 포함하여 객체에 연결된 모든 객체도 복사합니다.

모델 또는 도면에서 객체 이동

모델 또는 도면에서 객체를 이동하는 기본 방법은 원점과 하나 이상의 대상 점을 정의하는 것입니다.

  1. 이동할 객체를 선택합니다.

  2. 이동 명령을 실행합니다.
    • 모델의 경우, 편집 탭에서 이동을 클릭합니다.

    • 도면의 경우, 도면 탭에서 이동을 클릭합니다.

  3. 이동할 원점을 선택합니다.

    모델에서, Tekla Structures가 첫 번째 선택한 점과 커서 위치 사이에 고무 밴드 선을 표시합니다. 이것은 객체가 이동되는 위치의 미리 보기입니다. 커서를 움직여 미리 보기가 어떻게 변경되는지 확인합니다.

    Tekla Structures에서는 대상 점 선택 시 항상 커서의 위치가 아닌 객체가 이동될 위치에 미리보기를 표시합니다.

    미리 보기에 표시되는 객체 수를 제한하려면 XS_PREVIEW_LIMIT 고급 옵션을 사용합니다. 기본값은 1000입니다. 이 값이 0이면 미리 보기를 사용할 수 없습니다.

  4. 대상 점을 선택하십시오.

    객체가 바로 이동됩니다. 이동 명령은 활성 상태를 유지하지 않습니다.

모델이나 도면에서 원점과의 거리를 지정하여 객체 이동

원점과의 거리를 지정하여 모델 또는 도면의 새 위치로 객체를 이동할 수 있습니다. 숫자를 입력 대화 상자를 사용하여 거리를 지정합니다.

  1. 이동할 객체를 선택합니다.
  2. 이동 명령을 실행합니다.
    • 모델의 경우, 편집 탭에서 이동을 클릭합니다.

    • 도면의 경우, 도면 탭에서 이동을 클릭합니다.

  3. 이동할 원점을 선택합니다.
  4. 객체를 이동할 방향으로 커서를 움직이되, 점은 선택하지 마십시오.
  5. 거리를 입력합니다.

    입력을 시작하면 Tekla Structures에서 숫자를 입력 대화 상자를 자동으로 표시합니다.

  6. 확인을 클릭합니다.

모델 또는 도면에서 드래그 앤 드롭으로 객체 이동

모델이나 도면에서 객체를 새 위치로 드래그하여 이동할 수 있습니다.

  1. 드래그 앤 드롭을 활성화합니다.
    • 모델의 경우, 파일 메뉴에서 설정을 클릭하고 드래그 앤 드롭 확인란을 선택합니다.

    • 도면의 경우 파일 메뉴에서 설정을 클릭하고 도면 드래그 앤 드롭 확인란을 선택합니다.

  2. 이동할 객체를 선택합니다.

    도면에서 주석, 스케치 객체, 그리드 레이블을 드래그할 수 있습니다. 그리드 레이블을 이동하려면 먼저 그리드 레이블을 선택한 다음 그리드선 선택 선택 스위치를 활성화하거나 그리드 레이블 핸들을 선택합니다.

    자세한 내용은 도면 객체 드래그, 형상 조정 및 크기 조정을 참조하십시오.

  3. 객체를 새 위치로 드래그합니다.

    모델에서 드래그를 시작하는 점(중심, 모서리 또는 중간점)은 새 위치에서 객체의 정렬에 영향을 미칩니다.

    객체가 바로 이동됩니다.

  4. 드래그 앤 드롭으로 끝점을 이동하는 방법은 다음과 같습니다.
    1. 핸들을 선택합니다.
    2. 마우스 왼쪽 버튼을 누른 상태에서 핸들을 새 위치로 드래그합니다.

      다음과 같이 끝점이 적절하게 이동됩니다.

      참고로 일부 객체는 먼저 선택하지 않고 스마트 선택을 활성화하여 핸들에서 드래그해야 합니다. 스마트 선택을 켜려면 파일 > 설정을 클릭하고 스마트 선택 확인란을 선택합니다.

모델에서 객체를 선형 이동

모델에서 객체를 새 위치로 선형 이동할 수 있습니다.

  1. 이동할 객체를 선택합니다.
  2. 편집 탭에서 이동 > 선형을 클릭합니다.

    대화 상자가 이동 - 선형 열립니다.

  3. 모델에서 두 점을 선택하거나 dX, dY, and dZ 상자에 좌표를 입력합니다.

    공식을 사용하여 x, y 및 z 변위를 계산할 수도 있습니다. 예를 들면 아래 그림과 같습니다.

  4. 이동 기호를 클릭합니다.
팁:

대화 상자가 열려 있지만 명령이 더 이상 활성 상태가 아닌 경우에는 선택... 버튼을 클릭하여 명령을 다시 활성화합니다.

모델에서 객체를 다른 평면으로 이동

모델에서 지정한 첫 번째 평면의 객체를 지정한 두 번째, 세 번째 등의 평면으로 이동할 수 있습니다. 이동된 객체는 두 번째, 세 번째 등으로 지정한 평면에서의 위치가 첫 번째 평면에서의 원본 객체 위치와 동일하게 유지됩니다.

  1. 이동할 객체를 선택합니다.
  2. 편집 탭에서 이동 > 다른 평면으로을 클릭합니다.
  3. 첫 번째 평면의 원점을 선택합니다.
  4. 첫 번째 평면에서 양의 x 방향에 있는 점을 선택합니다.
  5. 첫 번째 평면에서 양의 y 방향에 있는 점을 선택합니다.
  6. 대상 평면에 3~5단계를 반복합니다.

모델에서 객체를 다른 객체로 이동

모델에서 한 객체의 객체를 다른 유사한 객체로 이동할 수 있습니다. 이것은 이전에 모델링한 부재를 상세히 표시할 때 유용합니다. 사이에 이동할 수 있는 객체마다 치수, 길이 및 회전이 다를 수 있습니다.

철근 또는 표면처리를 이동시키고 이를 이동 대상 부재에 적용하려면 다음 제한 사항을 참고하십시오.

  • 철근 또는 표면처리 핸들이 부재 모서리에 있어야 합니다.

  • 이동 대상 사이에 있는 부재는 단면 모서리 수가 같아야 합니다.

  • 원형 부재는 단면 치수가 동일해야 합니다.

  1. 이동할 객체를 선택합니다.
  2. 편집 탭에서 이동 > 다른 객체로을 클릭합니다.
  3. (소스 객체)에서 이동할 객체를 선택합니다.
  4. (대상 객체)로 이동할 객체를 선택합니다.
전송

Table of Contents